High latency when opening semaphoreci.com
Incident Report for Semaphore CI
Resolved
This incident has been resolved.
Posted 3 months ago. Apr 09, 2018 - 19:11 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 3 months ago. Apr 09, 2018 - 18:34 UTC
Investigating
We are currently investigating this issue.
Posted 3 months ago. Apr 09, 2018 - 18:28 UTC