apt-get update not working
Incident Report for Semaphore CI
Resolved
Posted Jul 13, 2021 - 15:18 UTC
Monitoring
The issue has been addressed on Semaphore 2.0
We are still evaluating the potential solutions for Semaphore Classic.

The problem should be addressed on the git-lfs side soon too.
Posted Jul 13, 2021 - 09:46 UTC
Identified
Due to the ongoing issue with git-lfs package, the apt-get update command is failing on Semaphore.

The issue on the git-lfs repository:
https://github.com/git-lfs/git-lfs/issues/4294#issuecomment-878778071

Our team is working on mitigating this problem and the repository in question will soon be removed from the image.

In the meantime, we suggest this quick workaround for fixing your workflows:

Before running the apt-get update command run the following command in your job:
sudo rm -f /etc/apt/sources.list.d/github_git-lfs.list
Posted Jul 13, 2021 - 08:00 UTC
This incident affected: Semaphore 2.0 and Semaphore Classic.