Network timeouts towards services relying on Fastly CDN
Incident Report for Semaphore CI
Resolved
At 2:55 UTC a routing change was applied towards Fastly CDN. All our tests are confirming that the issue is now resolved.
If you are still noticing intermittencies, please reach out to support@semaphoreci.com
Posted Apr 23, 2021 - 16:29 UTC
Update
We are seeing sporadic timeouts on traffic towards the services relying on Fastly CDN.

Following services seem to be affected so far:
hex.pm
rubygems.org
maven.org

In the meantime, the following workarounds are working:
- Add retry to `mix deps.get` as follows: `retry -t 10 mix deps.get`
- Use retry when installing bundler as follows: `bundle install --retry 10`

Our team is actively working with the upstream provider, hex.pm, and Fastly to pinpoint and resolve the issue.
Posted Apr 23, 2021 - 14:32 UTC
Investigating
We are seeing sporadic timeouts when attempting to reach hex.pm. Our team is actively working with the upstream provider to pinpoint and resolve the issue.

In the meantime, following workarounds are working:
- Use hex mirror - `HEX_MIRROR=https://hexpm.upyun.com mix deps.get`
- Add retry to `mix deps.get` as follows: `retry -t 10 mix deps.get`
Posted Apr 23, 2021 - 09:00 UTC
This incident affected: Semaphore 2.0.